[jpos-users] mux pool malfunction

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[jpos-users] mux pool malfunction

dannygaviria
Hi again.

I want to implement a mux-pool, the logon manager works perfectly, but at the moment of making a transaction does not process them, no connect with any channel.

Please help, thanks.


Channel 1

<channel-adaptor name='system1-channel-adaptor' class="org.jpos.q2.iso.ChannelAdaptor"
logger="Q2">
<channel class="org.jpos.iso.channel.BASE24ChannelSystem"
logger="Q2" packager="org.jpos.iso.packager.GenericPackager" header="ISO025000005" realm="system-channel-1">
<property name="packager-config" value="cfg/SystemPOSPackage.xml" />
<property name="host" value="127.0.0.1" />
<property name="port" value="9082" />
</channel>
<in>system1-send</in>
<out>system1-receive</out>
<reconnect-delay>10000</reconnect-delay>
</channel-adaptor>

Channel 2

<channel-adaptor name='system2-channel-adaptor' class="org.jpos.q2.iso.ChannelAdaptor"
logger="Q2">
<channel class="org.jpos.iso.channel.BASE24ChannelSystem"
logger="Q2" packager="org.jpos.iso.packager.GenericPackager" header="ISO025000005" realm="system-channel-2">
<property name="packager-config" value="cfg/SystemPOSPackage.xml" />
<property name="host" value="127.0.0.1" />
<property name="port" value="9082" />
</channel>
<in>system2-send</in>
<out>system2-receive</out>
<reconnect-delay>10000</reconnect-delay>
</channel-adaptor>

MUX 1

<mux class="org.jpos.q2.iso.QMUX" logger="Q2" name="system_mux-1">
<in>system1-receive</in>
<out>system1-send</out>
<ready>system1.ready</ready>
<unhandled>system-unhandled</unhandled>
<key>11, 41</key>

<request-listener class="com.System.jpos.ClientRequestListener"
logger="Q2" realm="myrealm1">
</request-listener>
</mux>


MUX 2

<mux class="org.jpos.q2.iso.QMUX" logger="Q2" name="system_mux-2">
<in>system2-receive</in>
<out>system2-send</out>
<ready>system2.ready</ready>
<unhandled>system-unhandled</unhandled>
<key>11, 41</key>

<request-listener class="com.System.jpos.ClientRequestListener"
logger="Q2" realm="myrealm2">
</request-listener>
</mux>

MUX POOL

<mux class="org.jpos.q2.iso.MUXPool" logger="Q2" name="system_mux">
<muxes>system_mux-1 system_mux-2</muxes>
<strategy>round-robin</strategy>
</mux>

Transaction manager:

<participant class="com.recargate.jpos.QueryHost" logger="Q2">
<property name="mux" value="system_mux" />
<property name="timeout" value="25000" />
<property name="threshold" value="12000" />
<property name="reverse-on-timeout" value="false" />
</participant>

Java code:

ISOMsg msg = new ISOMsg();
MUX mux = (MUX) NameRegistrar.get("mux.system_mux"));
ISOMsg response = mux.request(msg, 15000);
if (response != null) {
     return PREPARED;
}else{
    return ABORTED;
}




--
--
jPOS is licensed under AGPL - free for community usage for your open-source project. Licenses are also available for commercial usage. Please support jPOS, contact: [hidden email]
---
You received this message because you are subscribed to the Google Groups "jPOS Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jpos-users/d438d6cd-4413-40a6-bf43-5228dd98330d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Danny Gaviria
Reply | Threaded
Open this post in threaded view
|

Re: [jpos-users] mux pool malfunction

chhil
​The only thing I found a problem with is the 
<ready>system2.ready</ready><ready>system1.ready</ready>

It should be the channel adaptor name + .ready​

Try changing and see if it helps.

-chhil

--
--
jPOS is licensed under AGPL - free for community usage for your open-source project. Licenses are also available for commercial usage. Please support jPOS, contact: [hidden email]
---
You received this message because you are subscribed to the Google Groups "jPOS Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jpos-users/CAPazefAS6Z8%3DynL6wmhLEgkn95H5AFoG1%2BAjdPiH8d-Db%3DTDFA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [jpos-users] mux pool malfunction

dannygaviria
That is all!!!!!!

Thank you very much.

El miércoles, 9 de noviembre de 2016, 10:31:40 (UTC-4), chhil escribió:
​The only thing I found a problem with is the 
<ready>system2.ready</ready><ready>system1.ready</ready>

It should be the channel adaptor name + .ready​

Try changing and see if it helps.

-chhil

--
--
jPOS is licensed under AGPL - free for community usage for your open-source project. Licenses are also available for commercial usage. Please support jPOS, contact: [hidden email]
---
You received this message because you are subscribed to the Google Groups "jPOS Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jpos-users/e948ac2e-9f22-4742-a385-aa4323863598%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Danny Gaviria